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Getting Started 

Welcome 

Welcome to TalkMaster FOCUS VoIP Connect.   

VoIP Connect provides the ability to:  

 Initiate a 1-way audio page from a phone on a SIP based phone system to one or more IP 
Endpoints 

 Initiate a 2-way call from a phone on a SIP based phone system to a single IP Endpoint 

 Initiate a 2-way call from a single IP Endpoint to a phone on a SIP based phone system 

 During a 2-way call, the phone on the SIP based phone system can activate IP Endpoint's Relay 
to open a door 

VoIP Connect is comprised of the VoIP Connect Service and the VoIP Connect Configuration 
Console.  The VoIP Connect Service uses the configuration information from the VoIP Connect 
Configuration Console to create a SIP gateway between a SIP based phone system and the IP 
Endpoints.   

Release Notes 
V5.1.2 June 2016 

 Many stability enhancements for the VoIP Connect Service  

V5.1 November 2015 

 Initial Release as a Windows Service (replaced the SIP Media Gateway Console) 
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VoIP Connect Service 

VoIP Connect Service Logon 

The VoIP Connect Service typically runs on the same machine as the TalkMaster FOCUS Server 
service. The VoIP Connect Service must logon to the TalkMaster FOCUS Server in order to 
communicate with it, so an Operator UserID and Password needs to be supplied to it as a one-time setup. 
 Please Note that this Operator will always be logged on. 

  

To configure the logon information for the TalkMaster FOCUS VoIP Connect Service, launch the Voip 
Connect Service Configuration application from the Windows Start menu All Programs --> 
TalkMaster FOCUS --> VoIP Connect --> VoIP Connect Service Configuration.  

  

This console can also be used to display the current status of the service or to restart the service. 

 

Logon tab 
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 Username / Password - Enter the Username and Password fields that will be used by the VoIP 
Connect Service to login to the TalkMaster FOCUS Server service.  The Username must be 
defined in the Admin Console under the Operators tab 

 IP Address - Enter the IP Address of the TalkMaster FOCUS Server and the associated 
Console Port as defined in the Admin Console.  The Console Port defaults to 3010 

 Debug Tracking - This should be left unchecked unless instructed by Digital Acoustics Technical 
Support 

 Server Status - The Service Status area will display the current connection status of the service 

  

Save - Once the above changes have been made, press this button to apply the changes: 

 If the Server Status indicates that the Alert Management Service is running, but not connected 
to the TalkMaster FOCUS Server, it will try to logon immediately and the Server Status should 
change to Connected to iEnterprise 

  If the Server Status indicates that the Alert Management Service is not running, then select 
menu option Tools --> Restart Service to connect with the updated information 

  

OK - Press this button to save the changes and exit 

Cancel - Press this button to ignore the unsaved changes and exit 

  

  

  

VoIP Connect Service Network Adapter 

If the machine that the VoIP Connect Service is running on has multiple network adapters, select the 
Network Adapter that can communicate with the SIP based phone system. 
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VoIP Connect Configuration Console 

Setting Up Extensions 

Logon 

To start the VoIP Connect Configuration Console, open the Windows Start menu --> All Programs --> 
TalkMaster FOCUS --> VoIP Connect --> VoIP Connect Service Configuration.  The following logon 
dialog is displayed: 

 

 Logon ID - Enter the Logon ID as configured in the Admin Console --> Operators tab 

 Password -  Enter the associated password for the Logon ID 

 Address - Enter the IP Address and Console Port of the TalkMaster FOCUS Server. 

In the Admin Console on the Operators tab, check the Allow Multiple Logons checkbox for the 
Operator ID that is used for administering TalkMaster instead of creating a separate UserID for each 
configuration application 

Extensions tab 

The main screen allows you to see three different tabs of information. 
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 Extensions tab - This tab shows all of the extensions that have been assigned to either IP 
Endpoints or to Paging Groups 

 Devices tab - This tab shows all of the IP Endpoints that have been defined in the Admin 
Console and any extensions that have been assigned to them 

 Groups tab - This tab shows all of the Paging Groups that have been defined in the Admin 
Console and any extensions that have been assigned to them 

Column descriptions: 

 Name - Displays the name of the IP Endpoint or Paging Group that has been assigned an 
extension 

 SIP Status - Displays the SIP status of the IP Endpoint or Paging Group 

 Logon ID - Displays the extension that is assigned to the IP Endpoint or Paging Group 

 Intercoms Connected - Displays the number of IP Endpoints defined in the Admin Console and 
the number of them that are currently connected to the TalkMaster FOCUS Server service 

 Service SIP Server - Displays the address of the SIP Server that the TalkMaster FOCUS VoIP 
Connect Service is communicating with 

Devices tab 

The devices tab shows all of the IP Endpoints that are configured to connect to the TalkMaster Focus 
Server, their connection and SIP statuses. 
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 Device Location - The Location Name of the IP Endpoint that has been configured in the Admin 
Console 

 Status - The current status of the IP Endpoint in TalkMaster FOCUS Server 

 IP Address - The current IP Address of the IP Endpoint 

 SIP Status - The current SIP Status of the IP Endpoint in SIP Server 

 SIP Logon - The extension in the SIP Server that has been assigned to this IP Endpoint 

  

Device Extensions 

Device extension creation and editing is performed by double clicking on a device in a row. 
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 Extension Enabled - To enable a SIP extension for a device, check this box.  Then the SIP 
Extension, SIP Authentication Name, and Password are enabled and can be entered 

 Device Name - Displays the name of the IP Endpoint that has been defined in the Admin 
Console 

 MAC Address - Displays the network MAC Address of the IP Endpoint.  The last six digits are 
the ICOM ID 

 SIP Extension - The extension that is being assigned to this IP Endpoint and that has been 
defined in the SIP based phone system 

 SIP Authentication Name -  Some SIP based phone systems associate an Authenticated User 
ID with an extension and require it to be specified when logging on to the SIP based phone 
system.  If an Authentication ID is not required by the SIP based phone system, then enter the 
extension. Some systems refer to this field as the SIP Authorization Name 

 Password - The password that is assigned to the extension in the SIP based phone system. 
Some systems refer to this as the Secret 

 Out Dialing Extension Information 

 Out Dial this Device - Check this box to have the IP Endpoint dial an extension or phone 
number when it's TALK switch is engaged 
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 Out Dial when queue overflows - Check this box to have the IP Endpoint dial the 
extension or phone number when it's TALK switch is engaged AND when the TalkMaster 
FOCUS Server Queue it is in goes into Overflow status (as defined in the Admin 
Console).  A Queue can go into overflow status based on: 

 The amount of time that has passed since the IP Endpoint's TALK switch has 
been engaged 

 The current number of unanswered calls in the Queue 

 No TalkMaster FOCUS Server Operator is available to answer the call  

 Out Dial Extension Number -  Enter an extension or a phone number (including any 
digits required to get an outside line) to have the IP Endpoint dial 

 Default to Listen  - By default, a half-duplex call will be playing audio from the IP Endpoint to the 
call source.  If the default action should be to record audio from the IP Endpoint, check this option 

 Direct RTP Connection - If the RTP connection should be directly between the SIP Server and 
this IP Endpoint, check this option.  NOTE: This requires that the IP Endpoint is accessible and 
routable from the other endpoint  

 Use TCP Transport - The VoIP Connect will use the UDP Transport by default when creating 

SIP packets.  Check this box to use the TCP Protocol for SIP packets for this extension 

Groups tab 

 VoIP Connect can assign an extension defined on a SIP base phone system to a group of IP Endpoints. 
 This provides the ability to dial the extension and make an audio page to the IP Endpoints.   The Groups 
tab shows all of the Paging Groups, Status, and SIP status.TalkMaster FOCUS Server based  

 

  

Group Extensions 

Group extension creation and editing is performed by double clicking on a row for the group. 
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 Enabled Group - In order to edit this group, and for it to begin registering and be in use, the 
Enabled Group checkbox must be checked 

 Live or Queued radio button - Server based Paging Groups are defined in the Admin Console as 
either Live or Queued. When an audio page is sent to a Live group, the audio  is sent and 
played on the IP Endpoints while the operator is talking on the phone. There will be a 1 to 2 
second delay from the time the audio is spoken till it is played on the IP Endpoints.  For instances 
when the phone operator is in or near the speakers, a Queued group can be used.  For Queued 
groups, the phone operator's audio page is recorded and then sent to the IP Endpoints when the 
operator hangs up the phone 

 SIP Group Extension - The extension that is being assigned to this Paging Group and that has 
been defined in the SIP based phone system 

 SIP Group Authentication - Some SIP based phone systems associate an Authenticated User 
ID with an extension and require it to be specified when logging on to the SIP based phone 
system.  If an Authenication ID is not required by the SIP based phone system, then enter the 
extension 

 SIP Group Password - The password that is assigned to the extension in the SIP based phone 
system 

 Use TCP Transport - The VoIP Connect will use the UDP Transport by default when creating 
SIP packets.  Check this box to use the TCP Protocol for SIP packets for this extension 

OK - Saves the information and exits 

Cancel - Ignores any changes and exits 

Menu Options 

File Menu 

File->Logoff - Select this option to disconnect from the TalkMaster FOCUS Server without exiting the 
console application   
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File->Exit|- Select this option to disconnect from the TalkMaster FOCUS Server and exit the console 

application. 

 

Tools Menu 

Tools->Preferences - Opens a four tabbed dialog used to configure settings that the VoIP Connect 
Service used to communicate with the SIP Based phone system.  

Tools -> Support Settings - These settings should only be set when instructed by Digital Acoustics 
Support 

  

 

  

SIP Tab 

The SIP tab is used to configure the settings that the VoIP Connect Service will use to communicate 
with the SIP based phone system 
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 SIP Peer-to-Peer - Check this option to enable Peer-to-Peer mode. In Peer-to-Peer Mode, no 
Primary/Secondary SIP Server will be used.  Calls to and from IP Endpoints will need to specify 
the IP Address along with the extension of the device being called. To call extension 6110 located 
at IP Address 10.2.2.110, the dialing extension would be specified as 6110@10.2.2.110 

 The Primary SIP Server (also known as the Proxy Address) is typically the same as the 
Primary SIP Registrar. If this is different than the Primary Registrar, then the Use Registrar as 
Proxy box must be checked  

 Secondary SIP Server /Registrar - VoIP Connect Service supports a Secondary SIP Server.  If 
communication is lost with the Primary SIP Server, the VoIP Connect Server will attempt to 
register all of the defined extensions with the Secondary SIP server. If the Primary SIP Server 
becomes available again, VoIP Connect Service will re-register all of the devices with the Primary 
SIP Server 

 SIP Local / Ending Ports - Since each IP Endpoint / Paging Group will be registering with the IP 
Address of the VoIP Connect Service, each will need it’s own “port”.  Make sure to allocate at 
least as many ports as extensions that will be registered 

 RTP Port Range - Each SIP VoIP session (INVITE) will have a different RTP port pair.  Specify 
at least as two times as many ports as extensions 

 Seconds no data before hangup - This specifies how many seconds to wait between RTP 
packets before the VoIP Connect Service considers a call "timed out"  and aborts the call  
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 Use Registrar as Proxy - Some external SIP services expect the Server information to always 
be sent to a proxy address, rather than the Server address.  

 Re-register with fresh credentials - Some SIP server do not want the previously used 
credentials to be re-used.  Instead, they only want unused credentials when the REGISTER 
packet is sent  

 Allow Proxy Packets - This option specifies whether SIP Proxy Services are going to be sending 
packets from an address that is not the Server or the Registrar address. 

Cancel - Select this option to ignore any changes to the Preferences and exit to the main screen 

OK - Select this option to accept any changes to the Preferences and exit to the main screen 

Network tab 

The Network tab is used to configure some advance options  

  

External IP Addresss Info 

If a SIP Application Layer Gateway is available, then use that instead of changing any of these options. 

When a NAT'd firewall is betwen the VoIP Connect Service and the SIP based phone system, the 
external IP Address of the VoIP Connect Service must be passed in the SIP packets instead of the VoIP 
Connects local IP Address. 

 External IP Address -  Check this box and either enter the external IP Address of the VoIP 
Connect Service or enable to STUN option to automatically determine it 

 Use STUN - Check this option to automatically determine the External IP Address of the VoIP 
Connect Service the next time the VoIP Connect Service is restarted.  The results of the STUN 
testing will appear below Firewall Analysis. Some Firewalls will prevent this from working. 

 Non-Direct RTP Packets Between - If the audio path is running through the VoIP Connect 
Service (non-direct), the RTP Packet size can be specified to be between the two values shown, 
with a default “offer” of a number between those two values. 

  

Cancel - Select this option to ignore any changes to the Preferences and exit to the main screen 

OK - Select this option to accept any changes to the Preferences and exit to the main screen 

Paging tab 

The Paging Protocols tab is used to override how the TalkMaster FOCUS Server service sends audio 
to Paging Groups. Typically, this should use be set the same as the Admin Console --> Setup --> 
Paging Options tab 
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Audio tab 

This tab is used to setup audio options for SIP IP Endpoints. 

The Half Duplex Switching option determines how the audio direction is to be changed when 
communicating with Half Duplex IP Endpoints: 

 Key 0 switches Direction - When this option is selected, the phone operator presses the 0 
(zero) key on the phone to switch between Talking and Listening with an IP Endpoint 

 VAD / Automatic - When this option is selected, the audio level from the phone is monitored by 
the VoIP Connect Service and when it falls below the Threshold Level, the system will start 
sending audio from the IP Endpoint to the phone.  When the audio level rises above the 
Threshold Level. the system will start sending audio from the phone to the IP Endpoint.  Please 
note, that use of this setting requires a very quite environment around that phone and that it can 
take up to two seconds before the VoIP Connect Service gets enough data to determine when to 
switch the audio direction 

 Threshold Level - Specify the relative audio level received from the phone that the VoIP 
Connect Service will use to switch the audio direction 



VoIP Connect Configuration Console 

15 

 Allowed Codecs - The IP Endpoints support the uLAW and aLAW codecs  Specify at least one 
of them and make sure it is available on the SIP based phone system  
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Support 

Contacting Technical Support 

For Information on contacting Technical Support, please visit our web site at: 

www.digitalacoustics.com 

About Us 

Digital Acoustics, LLC 

www.digitalacoustics.com 

  

Digital Acoustics®, TalkMaster FOCUS®, ii3®, IP7®  and UBAM®  are trademarks of Digital Acoustics, 
LLC. All other marks used are properties of their respective owners. Digital Acoustics' product designs are 
packaged by leading manufacturers around the world. 

©  2007 - 2019 Digital Acoustics, LLC 

All Rights Reserved 

http://www.digitalacoustics.com/support
http://www.digitalacoustics.com/
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